#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^# dev(?!2\b)[0-9]+(?:\R(?!# dev[0-9]).*)*"
Local $sString = "# dev2" & @CRLF & _
"SAMETEXT %{URI} ^dev2-00.XXX.XXX.XXX" & @CRLF & _
"SAMETEXT %{URI} ^/XXX/" & @CRLF & _
"DIFFTEXT ^/XXX/(.*) https://XXX-XXX-XXX-XXX-dev2.XXX.XXX.XXX.XXX.XXX/XXX/$1 [X,Y]" & @CRLF & _
"" & @CRLF & _
"# dev1" & @CRLF & _
"SAMETEXT %{URI} ^dev2-00.XXX.XXX.XXX" & @CRLF & _
"SAMETEXT %{URI} ^/XXX/" & @CRLF & _
"DIFFTEXT ^/XXX/(.*) https://XXX-XXX-XXX-XXX-dev2.XXX.XXX.XXX.XXX.XXX/XXX/$1 [X,Y]" & @CRLF & _
"" & @CRLF & _
"# dev2" & @CRLF & _
"SAMETEXT %{URI} ^dev2-00.XXX.XXX.XXX" & @CRLF & _
"SAMETEXT %{URI} ^/XXX/" & @CRLF & _
"DIFFTEXT ^/XXX/(.*) https://XXX-XXX-XXX-XXX-dev2.XXX.XXX.XXX.XXX.XXX/XXX/$1 [X,Y]" & @CRLF & _
"" & @CRLF & _
"# dev21" & @CRLF & _
"SAMETEXT %{URI} ^dev2-00.XXX.XXX.XXX" & @CRLF & _
"SAMETEXT %{URI} ^/XXX/" & @CRLF & _
"DIFFTEXT ^/XXX/(.*) https://XXX-XXX-XXX-XXX-dev2.XXX.XXX.XXX.XXX.XXX/XXX/$1 [X,Y]" & @CRLF & _
"" & @CRLF & _
"# dev200" & @CRLF & _
"SAMETEXT %{URI} ^dev2-00.XXX.XXX.XXX" & @CRLF & _
"SAMETEXT %{URI} ^/XXX/" & @CRLF & _
"DIFFTEXT ^/XXX/(.*) https://XXX-XXX-XXX-XXX-dev2.XXX.XXX.XXX.XXX.XXX/XXX/$1 [X,Y]" & @CRLF & _
"" & @CRLF & _
"# dev921" & @CRLF & _
"SAMETEXT %{URI} ^dev2-00.XXX.XXX.XXX" & @CRLF & _
"SAMETEXT %{URI} ^/XXX/" & @CRLF & _
"DIFFTEXT ^/XXX/(.*) https://XXX-XXX-XXX-XXX-dev2.XXX.XXX.XXX.XXX.XXX/XXX/$1 [X,Y]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")