import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "# renovate: datasource=(?<datasource>.*?) depName=(?<depName>.*?)( versioning=(?<versioning>.*?))?\\s.*brew.*@\\s*['\\\"]?(?<currentValue>[v0-9].*?)['\\\"]?(\\s|$)";
final String string = "\n"
+ " - name: Install UDS CLI\n"
+ " shell: bash\n"
+ " # renovate: datasource=github-tags depName=defenseunicorns/uds-cli versioning=semver\n"
+ " run: brew install defenseunicorns/tap/uds@0.8.1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}