$re = '/(?:^|(?=.{5}$))!next/m';
$str = '!next
foo bar !next
!next foor bar
foo bar !next foo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);