re = /(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})/
str = '192.168.86.3 0x1 0x2 3cbbaxrad * br-lan 192.168.86.213 0x1 0x2 3cccfargarad * br-lan 192.168.86.51 0x1 0x2 3cccfcvrad * br-lan 192.168.86.11 0x1 0x2 3cccfxxrad * br-lan'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end