re = /:.*for(.+?);/m
str = 'Data Owner Approval Needed for Access Request #: 2137352 for NISHER HOSE; CONTRACTOR; Manager: MUILLER, TIM (TWM0069)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end