package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(>|=|<|~|>=|=<)?(1000)$`)
var str = `1000
<1000
~1000
>1000
>=1000
=1000
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}