$re = '@[/+;]|\s+(?:and|with)\s+@m';
$str = 'a;b;c
d/e/f
g and h
i with k
l + m';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);