package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*(?:[/+;]|and|with)\s*`)
var str = `a;b;c
d/e/f
g and h
i with k
l + m`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}