package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)AB|\S`)
var str = `11AB2AB33`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}