#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ix) (?(DEFINE)" & @CRLF & _
" (?<unreserved> [-._~[:alnum:]] )" & @CRLF & _
" (?<sub_delims> [!$&'()*+,;=] )" & @CRLF & _
" (?<pct_encoded> %[[:xdigit:]][[:xdigit:]] )" & @CRLF & _
" (?<pchar> @|(?&unreserved)|(?&pct_encoded)|(?&sub_delims) )" & @CRLF & _
" (?<seg_nz_nc> (?&pchar)+ )" & @CRLF & _
" (?<seg_nz> (?::|(?&pchar))+ )" & @CRLF & _
" (?<seg> (?::|(?&pchar))* )" & @CRLF & _
" (?<rootless> (?&seg_nz)(?:\/(?&seg))* )" & @CRLF & _
" (?<noscheme> (?&seg_nz_nc)(?:\/(?&seg)*) )" & @CRLF & _
" (?<absolute> \/(?:(?&seg_nz)(?:\/(?&seg))*)? )" & @CRLF & _
" (?<abempty> (?:\/(?&seg))* )" & @CRLF & _
" )" & @CRLF & _
" ^(?:(?&rootless)|(?&noscheme)|(?&absolute)|(?&abempty))$" & @CRLF & _
" "
Local $sString = "/bla/asd/f.fasdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")