re = /\d+(?=\s*NE)/
str = 'TDM - 02 Bundle Rehoming 5 NE
TDM - 02 Bundle Rehoming 23 NE
IP - 02 Bundle Rehoming 7 NE
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end