$re = '/,(?=\d+\.)/m';
$str = '45.51088930166307,51,52.52216552154544,75';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);