$re = '/400 people drive (?:dark blue )?cars/m';
$str = '400 people drive dark blue cars
400 people drive cars';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);