#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)me"
Local $sString = "https://lingojam.com/edit/02db819202047a0e482ab768cd7baec9" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###name, Name of your translator...:" & @CRLF & _
"IRC Server Now Understands Voice" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###subtitle, Subtitle (optional):" & @CRLF & _
"The Only Way" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###language1, Language1 name...:" & @CRLF & _
"Antonio Rodriguez Jr. Command To Anything" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###language2, Language2 name...:" & @CRLF & _
"Antonio Rodriguez Jr. Is Now Heard, Seen, Felt, Sense, And Vice Verca" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###description, Description...:" & @CRLF & _
"import java.util.Scanner" & @CRLF & _
"" & @CRLF & _
"Scanner stdin = new Scanner(System.in)" & @CRLF & _
"" & @CRLF & _
"public class Command" & @CRLF & _
"" & @CRLF & _
"{" & @CRLF & _
"public static void main(String[] args)" & @CRLF & _
"" & @CRLF & _
"{" & @CRLF & _
"" & @CRLF & _
" System.out.println("Command:");" & @CRLF & _
"" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###email, Admin email (optional)...:" & @CRLF & _
"wonderfulyanderful@gmail.com" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###phrases1, Language1...:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###phrases2, Language2...:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###words1, Language1...:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###words2, Language2...:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###intraword1, Language1...:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###intraword2, Language2...:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###prefixes1, Language1...:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###prefixes2, Language2...:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###suffixes1, Language1...:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###suffixes2, Language2...:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###regex1, Replace this...:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###regex2, with this...:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###rev_regex1, Replace this...:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###rev_regex2, with this...:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###ordering1, Language1...:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###ordering2, Language2...:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###defaulttext, One random default text string per line...:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###disable-reverse, :" & @CRLF & _
"on" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###custom-script, Define your functions here...:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###title-extra, e.g. '(and reverse translation)':" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###background-image-source, http://example.com/my_image.png:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###title-font-name, Name of custom font...:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###title-font-size, Size of title (default=5.5)...:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###language1-font, Language1 font...:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###language2-font, Language2 font...:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###language1-font-size, Language1 font size (default=24)...:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"###language2-font-size, Language2 font size (default=24)...:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")