using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=\d)(.+)(?=engineer)";
string input = @"""def grusol defno 1635 minos kalopo, ruso engineer okas puno""
""abc mysql 23 rufos kanso engineer""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}