$re = '/([a-zA-Z0-9_\-\.]+)@([a-zA-Z0-9_\-\.]+)\b/m';
$str = 'Example 1 (Colon)
Payee: John Smith
Account No: 145-567-981
Date: 19.01.2020
Time: 08:01
Email: JohnSmith@gmail.com.au
Example 2 (the dash)
John Smith - Payee
145 567 981 - Account No
19-01-2020 - Date
8:22 - Time
John.Smith@hotmail.edu.com - Email
Example 3 (the dashes AND all one line of text)
Payee - John Smith - Account No - 145.567.9815 - Date - 19,1,2020 - Time - 08:03:23 - Email - John.Z.Smith@Regex.is.cool.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);