import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{1,2}.\\d{1,2}.20\\d{2}";
final String string = "Example 1 (Colon)\n"
+ "Payee: John Smith\n"
+ "Account No: 145-567-981\n"
+ "Date: 19.01.2020\n"
+ "Time: 08:01\n"
+ "Email: JohnSmith@gmail.com\n\n"
+ "Example 2 (the dash)\n"
+ "John Smith - Payee\n"
+ "145 567 981 - Account No\n"
+ "19-01-2020 - Date\n"
+ "08:01 - Time\n"
+ "John.Smith@hotmail.com - Email\n\n"
+ "Example 3 (the dashes AND all one line of text)\n"
+ "Payee - John Smith - Account No - 145.567.9815 - Date - 19,1,2020 - Time - 08:01 - Email - John.Z.Smith@yahoo.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}