$re = '/\bstack\.com\b(?!\/wp-admin)/';
$str = 'Lorem Ipsum is http://stack.com text of the http://stack.com/wp-admin printing and typesetting industry.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);