$re = '/^((1?\d?\d|2[0-4]\d|25[0-5])(\.|$)){4}$/m';
$str = '43.167.0.255
43.167.0.255.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);