$re = '/([^\-]+)-/';
$str = 'embedded-software-entwickler';
$subst = "$1@";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;