# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\d+){1} ((\d+){1}.)/$3 /gm;t' <<< "140002 ЛЮБЕРЦЫ 2 ОКТЯБРЬСКИЙ ПР 123/4-115
636450 636450, Г. ТОГУР, УЛ. БЕЛИНСКОГО Д. 6 КВ 2
423571 423571 НИЖНЕКАМСК 1 ТАТАРСТАН ВАХИТОВА 51-171"