$re = '/(^02.{0}|^01.{1}|^0505.{0}|[0-9]{3})([0-9]+)([0-9]{4})/';
$str = '0211112222';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);