package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^a?b?c?d?$`)
var str = `abcde`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}