re = /(?<=Invalid items: \([^)]*)[^ ;)]+/m
str = 'Valid items: (aaa.com; bbb.com); Invalid items: (abc.def.com;); Valid items: (foo123;); Invalid items: (bar123;); Valid items: (1234; 5678; abcd;); Invalid items: (hello; world; 1212; 5566; aaaa;)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end