package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(?|\[([^][]*)]|(.))`)
var str = `cd/etc/init[BKSP][BKSP]it.d[ENTER]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}