$re = '/^([\w-\.]+)@(([?:[\w]+\.)+)[a-zA-Z]{2,4}$/';
$str = 'pslkd_234fj-ep@gm23ail.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);