re = /^(?=.{8,})(?=.*[a-z])(?=.*[A-Z])(?=.*[@#$%^!&*+=]).*$/m
str = 'W123a@fgffd
1232132
sdfdsfsW*qd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end