$re = '/(?<=\breturn base\.Channel\.)(?![^()]*Async)\w+/m';
$str = 'public System.Collections.Generic.List<MyItem> MyItemGroupList() {
return base.Channel.MyItemGroupList();
}
public System.Threading.Tasks.Task<MyItem> MyItemGroupListAsync(){
return base.Channel.MyItemGroupListAsync();
}
public OtherItem OtherItemByParam(string param) {
return base.Channel.OtherItemByParam(param);
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);