package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)one(( .+)(four).*|.*)`)
var str = `one two three four five six seven eight nine ten`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}