$re = '/^(x|y).*\1$/m';
$str = 'xyyyxyx
yxyxyxy
zxyxyxz
xyxyxyy
xgjyhdtfx
yjsaudgty
xuhgrey
yudgfsx
yaaay';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);