$re = '/([^a-z ])(?!(?<=2)00|(?<=20)0|(?<=200))/i';
$str = 'aBcd!@$24200323 200';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);