$re = '/\/([^!\/]*)\/[^!\/]*$/';
$str = 'de/bonprix/app/servermon/ServerMonUserInterface/0.0.5-SNAPSHOT/ServerMonUserInterface-0.0.5-20141002.113035-4.war';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);