$re = '/^(.*?)\s*(?:"(.*)")?\s*(?:\((.*)\))?$/m';
$str = 'textový záznam bla "A" (1)
textový záznam csa "B" (12)
textový záznam "C" (23)
textový záznam "X"
textový záznam (9)
textový záznam';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);