const regex = new RegExp('^[1-9]\\d{5}[1-9]\\d{3}((0[1-9])|(1[0-2]))(((0[1-9])|3[0-1])|(([1|2]\\d)|3[0-1]))\\d{3}([0-9]|X)$', 'g')
const str = `342501199002210613`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}