$re = '/(\d{1,3}(?:\.\d{1,3}){1,2})(?:\.\d{1,3})*/m';
$str = 'abc 1.2 1.2.3 1.2.3.4.5.6.7.8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);