using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<!\.)\d{1,3}(?:\.\d{1,3}){1,2})";
string input = @"abc 1.2 1.2.3 1.2.3.4.5.6.7.8";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}