$re = '/^.*[0-9]{6}$/x';
$str = '.AD2016121';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);