const regex = /^(?:[-+]?[1-8]?\d(?:\.\d{0,7})?|90(?:\.0{0,7})?),(?:[-+]?(?:180(?:\.0{0,7})?|(?:(?:1[0-7]\d)|(?:[1-9]?\d))(?:\.\d{0,7})?))$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[-+]?[1-8]?\\d(?:\\.\\d{0,7})?|90(?:\\.0{0,7})?),(?:[-+]?(?:180(?:\\.0{0,7})?|(?:(?:1[0-7]\\d)|(?:[1-9]?\\d))(?:\\.\\d{0,7})?))$', '')
const str = `38.303190,-77.457816`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}