$re = '/\[quote\](.*)\[\/quote\]/is';
$str = 'Hello, this is
an example post with multiple [quote]quotes from famous[/quote] people
For example [quote]this one[/quote] and others';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);