$re = '/^(?=.*Tim)(?=.*stupid).+/m';
$str = 'Tim is so stupid.
stupid Tim!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);