#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\s*?NAME\s*?:\s*?\"?)([0-9A-Za-z- ,]+)(?:\"?\s*?,\s*?)(?:DESCR\s*?:\s*\"?)([0-9A-Za-z- ,/+:]+)(?:\"?\s*?PID\s*?:\s*?)([0-9A-Z-]+)(?:\s*?,\s*?VID\s*?:\s*?)([0-9A-Z/]+)(?:\s*?,\s*?SN\s*?:\s*?)([0-9A-Z/]+)"
Local $sString = "NAME: "Chassis", DESCR: "Nexus C9348GC-FXP chassis"" & @CRLF & _
"PID: N9K-C9348GC-FXP , VID: V01 , SN: FFFFFFFFFFF" & @CRLF & _
"" & @CRLF & _
"NAME: "Slot 1 ", DESCR: "48x100M/1G "" & @CRLF & _
"PID: N9K-C9348GC-FXP , VID: V01 , SN: FFFFFFFFFFF" & @CRLF & _
"" & @CRLF & _
"NAME: "GEM ", DESCR: "4x25G+2x100G Switch "" & @CRLF & _
"PID: N9K-C9348GC-FXP , VID: V01 , SN: FFFFFFFFFFF" & @CRLF & _
"" & @CRLF & _
"NAME: "power Supply 1", DESCR: "PSU "" & @CRLF & _
"PID: NXA-PAC-350W-PE , VID: V01 , SN: DDDDDDDDDDD" & @CRLF & _
"" & @CRLF & _
"NAME: "power Supply 2", DESCR: "PSU "" & @CRLF & _
"PID: NXA-PAC-350W-PE , VID: V01 , SN: DDDDDDDDDDD" & @CRLF & _
"" & @CRLF & _
"NAME: "Fan 1 ", DESCR: "fan "" & @CRLF & _
"PID: NXA-FAN-30CFM-F , VID: N/A , SN: N/A" & @CRLF & _
"" & @CRLF & _
"NAME: "Fan 2 ", DESCR: "fan "" & @CRLF & _
"PID: NXA-FAN-30CFM-F , VID: N/A , SN: N/A" & @CRLF & _
"" & @CRLF & _
"NAME: "Fan 3 ", DESCR: "fan "" & @CRLF & _
"PID: NXA-FAN-30CFM-F , VID: N/A , SN: N/A"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)