using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\(\""STRCONNEXION\""\)?.=?.*)\""(.*?)\""";
string input = @"<SCRIPT LANGUAGE=""VBScript"" RUNAT=Server>
'Session_OnStart S'ex�cute la premi�re fois qu'un utilisateur utilise une page de votre application
'Session_OnEnd S'ex�cute en cas de d�passement du d�lai de la session d'un utilisateur ou quand celui-ci quitte votre application
'Application_OnStart S'ex�cute une fois lorsque la premi�re page de votre application est utilis�e pour la premi�re fois par un utilisateur
'Application_OnEnd S'ex�cute une fois lors de l'arr�t du serveur Web
Sub Session_OnStart
'Session(""STRCONNEXION"")=""wowoowow""
Session(""STRCONNEXION"")=""wowoowow""
'Session(""STRCONNEXION"")=""wowoowow""
Session.Timeout = 240
Session(""Connected"") = 0 ' Utilisateur n'est pas encore authentifie
Session(""langue"") = ""ita""
'Set Session(""SiteId"")
HostToSiteId
End Sub
Sub Session_OnEnd
Session.Abandon
end Sub
Sub Application_OnStart
Application(""Titre"") = ""GVI""
' Composants COM
Application(""AccesBannieres.Banniere"") = ""AccesBannieresGVI.Banniere""
Application(""AccesBatch.Batch"") = ""AccesBatchGVI.Batch""
Application(""AccesCheck.Check"") = ""AccesCheckGVI.Check""
Application(""AccesCibles.Cibles"") = ""AccesCiblesGVI.Cibles""
Application(""AccesCibles.Produits"") = ""AccesCiblesGVI.Produits""
Application(""AccesCommande.Commande"") = ""AccesCommandeGVI.Commande""
Application(""AccesCommunication.Communication"") = ""ACGVI.Communication""
Application(""AccesDepotVente.GestionCommande"") = ""AccesDepotVenteGVI.GestionCommande""
Application(""AccesDepotVente.InfosVo"") = ""AccesDepotVenteGVI.InfosVo""
Application(""AccesDepotVente.Mails"") = ""AccesDepotVenteGVI.Mails""
Application(""AccesEncheres.Administrateur"") = ""AccesEncheresGVI.Administrateur""
Application(""AccesEncheres.Cloture"") = ""AccesEncheresGVI.Cloture""
Application(""AccesEncheres.ListeCriteres"") = ""AccesEncheresGVI.ListeCriteres""
Application(""AccesEncheres.Utilisateur"") = ""AccesEncheresGVI.Utilisateur""
Application(""AccesFicheVO.FicheVO"") = ""AccesFicheVOGVI.FicheVO""
Application(""AccesInscriptions.Inscriptions"") = ""AIGVI.Inscriptions""
Application(""AccesListeVO.AlerteEmail"") = ""AccesListeVOGVI.AlerteEmail""
Application(""AccesListeVO.ListeCriteres"") = ""AccesListeVOGVI.ListeCriteres""
Application(""AccesListeVO.ListeCriteresDV"") = ""AccesListeVOGVI.ListeCriteresDV""
Application(""AccesListeVO.ListeVO"") = ""AccesListeVOGVI.ListeVO""
Application(""AccesListeVO.ListeVODV"") = ""AccesListeVOGVI.ListeVODV""
Application(""AccesLogin.Login"") = ""AccesLoginGVI.Login""
Application(""AccesMix.Mix"") = ""AccesMixGVI.Mix""
Application(""AccesParameters.Parameters"") = ""AccesParametersGVI.Parameters""
Application(""AccesPrevente.Prevente"") = ""AccesPreventeGVI.Prevente""
Application(""AccesPromotions.Administration"") = ""AccesPromotionsGVI.Administration""
Application(""AccesPromotions.Promotions"") = ""AccesPromotionsGVI.Promotions""
Application(""AccesReport.Reports"") = ""AccesReportGVI.Reports""
Application(""AccesStopAffaire.Administrateur"") = ""ASAGVI.Administrateur""
Application(""AccesStopAffaire.ListeCriteres"") = ""ASAGVI.ListeCriteres""
Application(""AccesStopAffaire.StopAffaire"") = ""ASAGVI.StopAffaire""
Application(""AccesSuiviHisto.SuiviHisto"") = ""AccesSuiviHistoGVI.SuiviHisto""
Application(""AccesVenteParLot.Administrateur"") = ""AVPLGVI.Administrateur""
Application(""AccesVenteParLot.ListeCriteres"") = ""AVPLGVI.ListeCriteres""
Application(""AccesVenteParLot.VenteParLot"") = ""AVPLGVI.VenteParLot""
Application(""AccesVisibilite.Visibilite"") = ""AccesVisibiliteGVI.Visibilite""
' Nombre de r�sultat par page dans la liste VO
Application(""PageToResult"") = 20
End Sub
Sub HostToSiteId
Dim audiHost, vwHost, currentHost
audiHost = ""www.audi-lineos.it""
vwHost = ""www.vgilineos.it""
currentHost = Request.ServerVariables(""HTTP_HOST"")
If currentHost = audiHost Then
Session(""SiteId"") = 1
Session(""SiteName"") = ""Audi""
End If
If currentHost = vwHost Then
Session(""SiteId"") = 2
Session(""SiteName"") = ""VW""
End If
If currentHost = ""localhost:8080"" Then
Session(""SiteId"") = 2
Session(""SiteName"") = ""VW""
End If
End Sub
</SCRIPT>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}