const regex = /(?!000)(?!900)(?!976)(?!800)(?!855)(?!866)(?!877)(?!888)^([0-9]( |-)?)?(\(?[0-9]{3}\)?|[0-9]{3})( |-)?([0-9]{3}( |-)?[0-9]{4}|[a-zA-Z0-9]{7})$/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!000)(?!900)(?!976)(?!800)(?!855)(?!866)(?!877)(?!888)^([0-9]( |-)?)?(\\(?[0-9]{3}\\)?|[0-9]{3})( |-)?([0-9]{3}( |-)?[0-9]{4}|[a-zA-Z0-9]{7})$', 'm')
const str = `889-722-8725`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}