#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^|(?:(?=(\w)(?!\1))).)(([A-Z])\3{3})(?:(?!\3)|$)"
Local $sString = "3346AAAA44" & @CRLF & _
"3973BBBBBB44" & @CRLF & _
"9755BBBBBBAAAA44" & @CRLF & _
"AAAAB" & @CRLF & _
"AAAA" & @CRLF & _
"BAAAA" & @CRLF & _
"AAAAA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")