package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\d+[dhms]){3,}`)
var str = `jihsdfj23jh453h4 1d12h30m10s jhsedfujht34uhji3g
например "12h30m10s" или "1d30m10s" или "1d12h30m"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}