$re = '/[^\d]+$/m';
$str = '2+3-4*
2-5+8/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);