$re = '/[^\d]+$/ms';
$str = '2+3-4*
2-5+8/
2232x
sass12a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);