re = /<(br|basefont|hr|input|source|frame|param|area|meta|!--|col|link|option|base|img|wbr|!DOCTYPE).*?<\/\1>/i
str = '<div>hello<h1>sdfs</h1></div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end