$re = '/^.*(?<!\d)/m';
$str = 'testuser1
testuser1-1
testuser1-2000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);