import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{1,2})[^\\d]{1,2}(\\d{1,2})(?:[^\\d]{1,2}(\\d{1,2}))?.*";
final String string = "S01E02E03\n"
+ "01x01 Lorem ipsum.avi Result: 01, 01\n"
+ "01x01-02 Lorem ipsum.avi Result: 01, 02 Expected: 01, 01, 02\n\n"
+ "1x1 Lorem ipsum.avi Result: 1, 1\n"
+ "1x1-2 Lorem ipsum.avi Result: 1, 2 Expected: 1, 1, 2\n\n"
+ "S01E01.HDTV.x264-LOL.mp4 Result: 01, 01\n"
+ "S01E01E02.HDTV.x264-LOL.mp4 Result: 01, 02 Expected: 01, 01, 02\n"
+ "S01E01-02.HDTV.x264-LOL.mp4 Result: 01, 02 Expected: 01, 01, 02\n"
+ "S01E01-E02.HDTV.x264-LOL.mp4 Result: 01, 02 Expected: 01, 01, 02\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}